您当前的位置:首页>linux频道>configure: error: cURL version 7.10.5 or later is required to compile php with cURL support

configure: error: cURL version 7.10.5 or later is required to compile php with cURL support

发布时间:2018-01-25 类型: linux频道 编辑: 小猪迷

    出现这个情况的,如果版本不够,那就升级,直接

    yum install curl

    然后查看一下版本

    curl --version

    结果

    curl 7.19.7 (x86_64-redhat-linux-gnu) libcurl/7.19.7 NSS/3.27.1 zlib/1.2.3 libidn/1.18 libssh2/1.4.2
    Protocols: tftp ftp telnet dict ldap ldaps http file https ftps scp sftp 
    Features: GSS-Negotiate IDN IPv6 Largefile NTLM SSL libz

    说明我的版本没有问题,那就是找不到的原因了,所以在编译的时候在

    --with-curl=/usr/local/bin/curl

    具休路径如下查找

    which curl

    得到结果便是路径

    /usr/local/bin/curl
  • 没有评论哦,快来抢个沙发吧
小猪迷

                

微信好友

用微信扫描二维码,
加我好友。

微信公众号

用微信扫描二维码,
订阅小猪迷公众号。

234113618

用微信扫描二维码,
加入小猪迷 QQ 群。

configure: error: cURL version 7.10.5 or later is required to compile php with cURL support -小猪迷PHP[xiaozhumi.com]

configure:error:cURLversion7.10.5orlaterisrequiredtocompilephpwithcURLsupport

https://www.xiaozhumi.com/linux/125.html